参考

Kubernetes v1.13 版本的文档已不再维护。您现在看到的版本来自于一份静态的快照。如需查阅最新文档,请点击 最新版本。

Edit This Page

将Kubernetes集群升级到指定版本。

简介

将Kubernetes集群升级到指定版本。

kubeadm upgrade apply [version]

选项

--allow-experimental-upgrades
显示 Kubernetes 的不稳定版本作为升级替代方案,并允许升级到 Kubernetes 的 alpha/beta 或 RC 版本。
--allow-release-candidate-upgrades
显示 Kubernetes 的候选版本作为升级替代方案,并允许升级到 Kubernetes 的 RC 版本。
--config string
kubeadm 配置文件的路径(警告:配置文件的使用是实验性的)
--cri-socket string     Default: "/var/run/dockershim.sock"
指定要连接的 CRI 套接字。
--dry-run
不要更改任何状态,只输出要执行的操作。
--etcd-upgrade     Default: true
执行 etcd 的升级。
--feature-gates string
一组键值对,用于描述各种功能的功能门。选项包括:
Auditing=true|false (ALPHA - default=false)
CoreDNS=true|false (default=true)
DynamicKubeletConfig=true|false (BETA - default=false)
-f, --force
强制升级,但可能无法满足某些要求。这也意味着非交互模式。
-h, --help
帮助
--ignore-preflight-errors stringSlice
一系列检查,其错误将显示为警告。示例:'IsPrivilegedUser,Swap'。值'all'忽略所有检查的错误。
--image-pull-timeout duration     Default: 15m0s
等待控制面 pod 下载的最长时间。
--kubeconfig string     Default: "/Users/zarnold/.kube/config"
与集群通信时使用的 KubeConfig 文件。如果未设置标志,则在相关目录下搜索以查找现有KubeConfig文件。
--print-config
指定是否应打印将在升级中使用的配置文件。
-y, --yes
执行升级,不提示确认(非交互模式)。

从父命令继承的选项

--rootfs string
[EXPERIMENTAL] 宿主机根文件系统的路径。

反馈